Cisco Routing Basics

The page describes a series of YouTube videos which explain the basics of routing utilising Packet Tracer.  The intructions are intended to assist students who are just starting to learn about configuring Cisco routers and explore some simple networks using static, RIP and RIPv2 routing configurations.  I’ve made each of the videos to be less than 5 minutes each, so that it’s easy to review just the parts you require…and because that was a limitation in using Jing (which I used to create the videos).

The Videos can be found here: http://www.youtube.com/user/TechWazza/

Create the simple network

The first step is to create the the simple network as shown in the image “Simple Packet Tracer Router Network” below. How to do this is shown in the video: http://www.youtube.com/user/TechWazza/#p/a/u/3/Ko_Egiy2VDA.

Simple Packet Tracer Router Network

Simple Packet Tracer Router Network

Configure the PCs and Routers

In the second video I show how to configure IP address on the PC and Router interfaces. Click http://www.youtube.com/user/TechWazza/#p/a/u/2/_vhVx2CsUlc to go the YouTube video.

The commands which are typed in to the left router are also shown here and will appear something like the following when typed (I’ve only included the lines in which the user typed something).

Router>enable
Router#configure terminal

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface serial 0/1/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown

The configuration of the router on the right hand side will be very similar.  However, the IP addresses will be different and dependant on which end of the serial connection (between the routers) has the DCE end the “clock rate” command should not be required.  Rather than typing the commands in it is possible to past a series of confiugaration commands in and to have them executed one after the other.  While I don’t recommend you do this while you are learning showing the configurations in this format is a short hand way of making the configuaration of the routers clear.  As such the following shows the configuarion of both the left and right hand side router from the previous image.

!
! Configuration for the left hand router
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
!
interface Serial0/1/0
ip address 192.168.2.1 255.255.255.0
clock rate 64000
no shutdown

!
! Configuration for the right hand router
!
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
no shutdown
!
interface Serial0/1/0
ip address 192.168.2.2 255.255.255.0
no shutdown

Adding Static Routes

Once all the interfaces are configured to allow all devices to communicate the routes need to be communicated.  To do this in this instance we add static routes.  We can see this in the video: http://www.youtube.com/user/TechWazza/#p/a/u/1/MuMUljtjCbo.

The actual route commands required on the routers are as follows

! route for left hand router
ip route 192.168.3.0 255.255.255.0 Serial0/1/0

! route for right hand router
ip route 192.168.1.0 255.255.255.0 Serial0/1/0

Using RIP instead of static routes

Instead of adding static routes to get the network to operate correctly it is possible to use a routing protocol. In this video we use the same network as originally created but without the static routes from the previous step. Instead the video shows how to setup RIP to communicate routing information between routers.  The video is here: http://www.youtube.com/user/TechWazza/#p/a/u/0/KPQXf8y7ndI.

The necessary RIP commands for both the routers are as follows.

! commands for the left hand router
router rip
network 192.168.1.0
network 192.168.2.0

! commands for the right hand router
router rip
network 192.168.3.0
network 192.168.2.0

RIP version 2 and why

RIP version 1 is a classful routing protocols.  This means that it doesn’t provide a subnet mask in routing updates to other routers and as such it doesn’t support certain network and subnet arrangements.  I will not go into too much detail here as you can find out more from the CCNA course material.  However, I provide a simple example here of a network in which RIP version 1 would not work to advise the neigbouring router of known routes correctly.

Using the same network topology as initially shown use the following three subnets to provide IP addresses.  The subnets are 10.1.1.0/24,   192.168.2.0/24,  and 10.1.3.0/24.  The configuration of the routers is as follows.

! configuration for left hand router

interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
no shutdown
!
interface Serial0/1/0
ip address 192.168.2.1 255.255.255.0
clock rate 64000
no shutdown
!
router rip
network 10.0.0.0
network 192.168.2.0

! configuration for right hand router

interface FastEthernet0/0
ip address 10.1.3.1 255.255.255.0
no shutdown
!
interface Serial0/1/0
ip address 192.168.2.2 255.255.255.0
no shutdown
!
router rip
network 10.0.0.0
network 192.168.2.0

This configuration requires the LHS PC has an IP address of 10.1.1.2 and the RHS PC has an address of 10.1.3.2.

When this network is setup with these configurations you will find that the PCs will not be able to ping each other.  The reason being that a class C network address (192.168.2.0)  is between two subnetted class A addresses (10.0.0.0). There are several commands which will assist to verify this.  The first command is “show ip route”.  This command will show the routes in the route table.  Another command is “debug ip rip”, which can be reversed with “no debug ip rip”, but while it’s on you get an idea what routing information passes between the routers.

To get this network to work and for each router to be aware of all routes all that is required is to add the “version 2” into the RIP configuration.  This changes the RIP protocol from version 1 to version 2 and turns it from a classful protocol to a classless protocol.  In effect it allows for the subnet mask to be transferred with a network and therefore, in this instance, the routers can now learn about the networks the other rotuers have attached.  Below I show the complete configuration with the “version 2” and “no auto-summary” settings added in.  I suggest you initially just add the version 2 setting by going into the configuration mode and first typing “router rip” and then at the prompt typing “version 2 – it should look somehting like this: Router(config-router)#version 2.  Once done on both routers the network should work and you can check with “show ip route” command.  You can then add the “no auto-summary” setting to see what happens, but to do that you’ll need to use the “show ip route” command again.  Anyway the complete RIP version 2 configuration for the network is as follows.

! configuration for left hand router

interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
no shutdown
!
interface Serial0/1/0
ip address 192.168.2.1 255.255.255.0
clock rate 64000
no shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.2.0
no auto-summary

! configuration for right hand router

interface FastEthernet0/0
ip address 10.1.3.1 255.255.255.0
no shutdown
!
interface Serial0/1/0
ip address 192.168.2.2 255.255.255.0
no shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.2.0
no auto-summary

The IP addresses on the computers are the same as set previously (i.e. LHS PC has an IP address of 10.1.1.2 and the RHS PC has an address of 10.1.3.2).

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s




%d bloggers like this: